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Abstract— This paper proposes a Surveillance Robot system 

that utilizes IoT technology and an Android application to 

enhance security and surveillance measures. The system is 

powered by a solar panel and a 12V battery, providing 

continuous power supply for uninterrupted surveillance. The 

Surveillance Robot is equipped with a PIR motion detector that 

detects the presence of any person and triggers a high audio 

alert to notify the monitoring authorities. The front end of the 

Robot features an ESP32 IoT camera that provides a clear 

view of nearby images and war field status, with a laser used 

for shooting the person. The integration of IoT technology and 

the Android application enables the system to be remotely 

accessed and monitored, making it highly versatile and user-

friendly. The proposed Surveillance Robot system offers an 

efficient and effective solution for enhancing security measures 

in various settings, with the potential to revolutionize the field of 

surveillance and security. 

 

Keywords— Solar photovoltaic (SPV), DC-DC boost converter, Maximum power point tracking (MPPT), Voltage source converter (VSC), Load balancing, Power Quality (PQ), 

Power balance theory (PBT. 

I. INTRODUCTION 

The current era is characterized by the increasing 

importance of security and surveillance in various 

settings. With the advent of advanced technology, 

researchers and engineers are consistently exploring 

innovative ways to design and implement highly 

efficient and effective systems for enhancing 

security measures. The proposed system, a 

Surveillance Robot controlled through an Android 

application using IoT technology, is an exemplary 

development that can revolutionize the field of 

surveillance and security. 

The Surveillance Robot system is equipped with 

several components that enable it to operate 

efficiently and reliably. A solar panel and 12V 

battery are used to power the robot, providing 

continuous power supply even in the absence of 

electricity. This ensures that the system operates 

optimally without interruptions, thereby providing 

continuous surveillance and monitoring. 

The Surveillance Robot also comes equipped with a 

PIR (Passive Infrared) motion detector that detects 

the presence of any person in the vicinity. The 

detector is highly sensitive and can pick up even 

slight movements, which triggers a high audio alert 

that immediately notifies the monitoring authorities. 

The audio alert system serves as a critical feature of 

the Surveillance Robot system, allowing quick and 

timely action to be taken in the event of suspicious 

activity. 

The front end of the Surveillance Robot features an 

ESP32 IoT camera that provides a clear view of 

nearby images and war field status. The camera is 

designed to capture high-quality images and videos 

that can be used to identify any suspicious activity 

or to monitor the overall situation in the 

environment. Additionally, a laser is used for 

shooting the person, providing an added layer of 

security and protection. 

 

The integration of IoT technology enables the 

Surveillance Robot system to be controlled through 

an Android application, allowing for remote access 

and monitoring. The Android application provides 

the user with real-time access to the surveillance 

system, enabling them to control and monitor the 

Robot from anywhere in the world. This feature 

makes the system highly versatile and user-friendly, 
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enabling it to be used in a wide range of settings and 

environments. 

 

In conclusion, the proposed Surveillance Robot 

system offers a highly efficient and effective 

solution for enhancing security measures. The 

system is designed to provide continuous 

surveillance and monitoring, even in the absence of 

electricity. The integration of IoT technology and 

the Android application makes the system highly 

versatile and user-friendly, while the PIR motion 

detector, audio alert system, and the ESP32 IoT 

camera make it highly reliable and efficient. This 

innovative development has the potential to 

revolutionize the field of surveillance and security, 

providing a reliable and effective solution for 

monitoring and securing various environments. 

 
II.  PROPOSED SYSTEM 

This Surveillance Robot is controlled through 

Android Application using IOT. This Robot is 

powered using a Solar Panel and a 12V Battery to 

provide continuous power to Robot. It is Equipped 

with PIR motion Detector, which detect any 

presence of person and give a High Audio Alert to 

the Monitoring Authorities. A ESP32 IOT Camera 

is used in the Front end of this Robot, to get clear 

view of nearby image and War field status a laser is 

used for shooting the person. The following picture 

will show the proposed system. 

 
Fig 1(a): Proposed System 

 

 
Fig 1(b): Proposed System 

III. LITERATURE SURVEY 

1. Raja et al. (2018) introduced a wearable device 

called MASS (Military Assistance and Surveillance 

System) that utilizees various sensors to monitor 

soldiers, including location, health conditions, and 

surroundings. It sends data to a base station, and the 

device also monitors pulse rate and transmits it to 

the base station using a GPS module. 

2. Ghute et al. (2018) described a military 

surveillance robot system consisting of a single unit. 

It uses gyro sensors for navigation in hilly areas and 

metal detection for landmines. The system employs 

Bluetooth connectivity for wireless communication 

through a mobile application, limiting its range. 

3. Prakash et al. (2018) presented a simple military 

surveillance robot controlled via remote commands. 

The Raspberry Pi 3 receives instructions and moves 

the robot accordingly. The Kinect sensor acts as a 

camera with depth measurement capabilities, 

providing grayscale representations of objects based 

on their distance. 

4. Bolisetti et al. (2017) proposed an RF sensing-

based target detector for energy-efficient target 

detection in harsh sensing environments. Sensor 

nodes make preliminary decisions before 

transmitting data to the control center, reducing the 
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frequency of data exchange and increasing the 

lifetime of the IoT. 

5.ElhajAbdalla et al. (2017) implemented a spy 

robot using a Raspberry Pi-based surveillance 

system with remote monitoring and control through 

IoT. PIR sensors detect living objects, and the 

information is sent to users via a web server. The Pi 

camera captures moving objects, which are 

simultaneously posted on a web page. 

6. Majdghareeb et al. (2017) introduced a wireless 

robo-pi for landmine detection, aiming to replace 

human detectors. The detector wirelessly connects 

with a server to transmit the location of detected 

mines or images of the suspected area. The system 

can be made IoT-based for further communication. 

7. Budiharto et al. (2014) designed a tracked robot 

with remote control for surveillance. It uses a 2.4 

GHz video transmitter to deliver video streaming 

from the Raspberry Pi output. The robot's 

performance and sensor system are cost-effective, 

but ultrasonic sensors have limitations in 

identifying obstacles and interference between 

sensors. 

8. Claudi et al. (2012) proposed a mobile 

autonomous robot called MARVIN for video 

surveillance. Its main objective is to detect human 

faces and autonomously keep a face in the center of 

the frame. The architecture of the robot achieves a 

balance between reactivity and accuracy, using real-

time face-detection algorithms like LBP (Local 

Binary Patterns) for speed and accuracy. 

9. Zheng et al. (2009) presented a miniature 

autonomous surveillance robot called BMS-1. It 

utilizes a flexible driving mechanism and 

spyroelectric sensors specifically designed for 

human motion detection. Photovoltaic sensors help 

detect dark locations for the robot's covert 

operations. 

 

 

 

IV. BLOCK DIAGRAM 

 

 

  Fig 2: Block Diagram of Multipurpose Surveillance Robot 

 

V. HARDWARE COMPONENTS 
 

The monitoring system contains several 

components like power supply, ESP32, etc. 

This chapter gives a detailed review of each 

of this part along with its working. 

 
• Solar panel 

• Rechargeable battery 

• Node MCU ESP8266 

• Buzzer 

• L293D Motor driver 

• Green LED 

• Laser 

• ESP32 CAM 

• RED LED 

• PIR Sensor 

• Blynk IoT Server 
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VI.   SOFTWARE 

 

ARDUINO UNO INSTALLATION:   

 In this we will get know of the process of 

installation of Arduino IDE and connecting 

Arduino uno to Arduino IDE 

 

Step 1: First we must have our Arduino board (we 

can choose our favorite board) and a USB cable. In 

case we use Adriana UNO, Arduino Duemilanove, 

Nano, Arduino Mega 2560, or Diecimila, we will 

need a standard USB cable (A plug to B plug), t In 

case we use Arduino Nano, we will need an A to 

Mini-B cable. 

 

Step 2 − Download Arduino IDE Software. We can 

get different versions of Arduino IDE from the 

Download page on the Arduino Official website. 

We must select wer software, which is compatible 

with wer operating system (Windows, IOS, or 

Linux). 

After wear file download is complete, unzip the file 
 

 

Step 3 − Power up our board. The Arduino Uno, 

Mega, Duemilanove and Arduino Nano 

automatically draw power from either, the USB 

connection to the computer or an external power 

supply. If we are using an Arduino Diecimila, we 

have to make sure that the board is configured to 

draw power from the USB connection. The power 

source is selected with a jumper, a small piece of 

plastic that fits onto two of the three pins between 

the USB and power jacks. Check that it is on the 

two pins closest to the USB port. Connect the 

Arduino board to wer computer using the USB 

cable. The green power LED (labeled PWR) should 

glow. 

 

Step 4 − Launch Arduino IDE. 

 

 
 

After our Arduino IDE software is downloaded, we 

need to unzip the folder. Inside the folder, we can 

find the application icon with an infinity label 

(application.exe). 

Double click the icon to start the IDE. 

 

Step 5 − Open our first project. 

Once the software starts, we have two options  

• Create a new project 

 

• Open an existing project example. 

To create a new project, select File → New. 
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To open an existing project example, select File → 

Example → Basics → Blink. 

Here, we are selecting just one of the examples with 

the name Blink. It turns the LED on and off with 

some time delay. We can select any other example 

from the list. 

 

Step 6 − Select our Arduino board . To avoid any 

error while uploading wear program to the board, 

we must select the correct Arduino board name, 

which matches with the board connected to wer 

computer. 

Go to Tools → Board and select wear board. 

Here, we have selected Arduino Uno board 

according to our tutorial, but we must select the 

name matching the board that we are using. 

 

Step 7 − Select wer serial port. 

Select the serial device of the Arduino board. Go to 

Tools → Serial Port menu. This is likely to be 

COM3 or higher (COM1 and COM2 are usually 

reserved for hardware serial ports). To find out, 

we can disconnect wer Arduino board and re-open 

the menu, the entry that disappears should be of the 

Arduino board. Reconnect the board and select that 

serial port. 

Step 8 − Upload the program to wer board. 

Before explaining how we can upload our program 

to the board, we must demonstrate the function of 

each symbol appearing in the Arduino IDE toolbar. 

Select the serial device of the Arduino board. Go to 

Tools → Serial Port menu. This is likely to be 

COM3 or higher (COM1 and COM2 are usually 

reserved for hardware serial ports). To find out, we 

can disconnect wer Arduino board and re-open the 

menu, the entry that disappears should be of the 

Arduino board. Reconnect the board and select that 

serial port 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

BLYNK APP 

Blynk was designed for the Internet of Things. It 

can control hardware remotely, it can display sensor 

data, it can store data, vizualize it and do many other 

cool things. 

There are three major components in the platform: 

• Blynk App - allows to you create amazing 

interfaces for your projects using various 

widgets we provide. 

• Blynk Server - responsible for all the 

communications between the smartphone 

and hardware. You can use our Blynk Cloud 
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or run your private Blynk server locally. It’s 

open- source, could easily handle thousands 

of devices and can even be launched on a 

ESP32. 

 

• Blynk Libraries - for all the popular 

hardware platforms - enable communication 

with the server and process all the incoming 

and outcoming commands. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

VII. CONCLUSION 

 

This robot was built by keeping military 

applications in mind. So, it comes with basic video 

surveillance and human detection so that it can 

detect underground persons etc. Further extensions 

are can be made in the same projects such as home 

automation, telemedicine system.The robot can be 

equipped with interactive voice feedback. It is 

possible to install ME (medical emergency) band 

in the robot to look after the health of an elderly 

person in the house. 
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