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Abstract—.This paper proposes to enhance current earthquake 

warning systems, rising technologies, including social and mobile 

computing, have been the focus of much attention.It is now possible 

to capture various kinds of motion using a smart phone's sensors, 

(e.g., accelerometer, vibration, etc.) including earthquake motion. 

To that end, we developed smart phone software to capture and 

backend analytics to determine whether the motion captured by a 

smart phone is caused by an earthquake or by human motion. In so 

doing, our goal is to establish a new type of seismic network using 

smart phones which enhance traditional seismic networks. In this 

paper, we evaluated the use of mems as detection devices; collected 

both human and simulated earthquake data using the mems and 

water level sensor, and developed an algorithm to distinguish 

earthquakes from human activities. Our results show that using 

our algorithms, a smart phone or computer can not only be used as 

a recording instrument, but also a highly accurate earthquake 

detection tool. As a result, creating networks of axis sensors based 

on smart phones will enhance the safety of communities vulnerable 

to earthquakes, worldwide. The gateway which has the sensor node 

receiver and acts as an message transfers the warning to smart 

phones. Finally, many of the human lives can be saved. 

 
I. INTRODUCTION 

Earthquake and tsunami constitute the worst natural 

hazards which often turn into disaster causing wide spread 

destruction and lose of human life and property. Effects of 

earthquake vary up on magnitude and intensity. Earthquake 

occurs every now and then all-round the world except in some 

places where earthquake occurs rarely. The devastation of cities 

and towns is one of the effects of earthquake. When earthquake 

strikes on track the bed of the ocean, millions of tons of water 

are suddenly pushed upwards or sinks dramatically downwards 

thus generating a powerful wave which causes tsunami. 

 
Earthquake early warning (EEW) is the delivery of ground 

shaking alerts or warnings. It is distinguished from prediction in 

that the earthquake has nucleated to provide detectable ground 

motion when an EEW is issued. The warning time available is 

the time between detection and when ground motion is 

experienced by a user. Potential warning times are therefore 

seconds to minutes. 

Tsunami is a system of ocean gravity waves formed as a 

result of large-scale disturbance of the sea floor that occurs in a 

relatively short duration of time. The Indian Ocean is likely to 

be affected by tsunamis generated mainly by earthquakes from 

the two potential source regions, the Andaman-Nicobar- Sumatra 

Island Arc and the Makran Subduction Zone. A state- of-the-art 

warning centre has been established at INCOIS with all the 

necessary computational and communication infrastructure that 

enables reception of real- time data from the network of national 

and international seismic stations, tide gauges and bottom 

pressure recorders (BPRs). Earthquake parameters are computed 

in the less than 15 minutes of occurrence. A database of pre-run 

scenarios for travel times and run-up height has been created 

using Tsunami N2 model. At the time of event, the closest 

scenario is picked from the database for generating advisories. 

Water level data enables confirmation or cancellation of a 

tsunami. Tsunami bulletins are then generated based on decision 

support rules and disseminated to the concerned authorities for 

action, following a standard operating procedure. The criteria for 

generation of advisories (warning/alert/watch) are based on the 

tsunamigenic potential of an earthquake, travel time (i.e. time 

taken by the tsunami wave to reach the particular coast) and 

likely inundation. The performance of the system was tested on 

September 12, 2007 earthquake of magnitude 8.4 off Java coast. 

The system performed as designed. It was possible to generate 

advisories in time for the administration and possible evacuation 

was avoided. 

 
II. PROPOSED SYSTEM 

 

In this project, we are designing earthquake and tsunami 

alerting system using Arduino, MEMS sensor and water level 

sensor which is used to alert the people about an earthquake and 

tsunami using GSM module. 

 

This system can also generate the seismic graph on the 

screen of the laptop to analyze the data of the intensity of the 

earthquake. 
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Fig 1(a): Earthquake 
 

 

Fig 1(b): Tsunami 

 

III. DESCRIPTION OF PROJECT 

 
In this project, we are designing earthquake and tsunami 

alerting system using Arduino, MEMS sensor and water level 

sensor which is used to alert the people about an earthquake and 

tsunami using GSM module. 

 

Firstly, the power supply of 12v is given to AT mega 

328 microcontroller. MEMS sensor continuously senses 

thevibration and sends the information to AT mega 328 

microcontroller. The main function of microcontroller is to 

compare calculated value with threshold value. If it is greater 

than threshold value microcontroller activates buzzer and red 

light will be turned on and a message will be sent. If it less than 

threshold value than green light will be turned on. 

Water level sensor senses the level of water and sends the 

information to microcontroller. If its range is greater than 

threshold value it activates buzzer and red light will be turned on 

and a message will be sent. If its range is less than threshold value 

than green light will be turned on. 

This system can also generate the seismic graph on the screen 

of the laptop to analyze the data of the intensity of the earthquake. 

Our results show that using our algorithms, a smart phone or 

computer can not only be used as a recording instrument, but also a 

highly accurate earthquake detection tool. As a result, creating 

networks of axis sensors based on smart phones will enhance the 

safety of communities vulnerable to earthquakes, 

worldwide.BLOCK DIAGRAM 

 

 

 

 

 

 

Fig 2: Block Diagram of Early warning system for Earthquake 

and Tsunami 

 

 
IV. HARDWARE COMPONENTS 

 

The monitoring system contains several components 

like power supply, ESP32, etc. This chapter gives a detailed 

review of each of this part along with its working. 

◆ ATMEGA328 Microcontroller 

◆ MEMS Sensor 

◆ Water level sensor 

◆ Buzzer 

◆ Green LED 

◆ RED LED 

◆ USB 

◆ GSM 

 
V. HARDWARE DESCRIPTION 
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A. ARDUINO NANO: 

The Arduino nano is a microcontroller board based 

on the ATmega328. It has 14 digital input/output pins (of 

which 6 can be used as PWM outputs), 6 analog inputs, a 16 

MHz ceramic resonator, a USB connection, a power jack, an 

ICSP header, and a reset button. It contains everything needed 

to support the microcontroller; simply connect it to a 

computer with a USB cable or power it with a AC-to-DC 

adapter or battery to get started. 
 

 

 
Fig4:Arduino nano 

B.MEMS SENSOR: 

MEMS (micro electro-mechanical systems) 

technology has gone from an interesting academic exercise to an 

integral part of many common products. But as with most new 

technologies, the practical implementation of MEMS technology 

has taken a while to happen. The design challenges involved in 

designing a successful MEMS product (the ADXL2O2E) are 

described in this article by Harvey Weinberg from Analog 

Devices. In early MEMS systems a multi-chip approach with the 

D. Buzzer: 

A buzzer or beeper is an audio signaling device, which may 

be mechanical, electromechanical, or piezoelectric. Typical uses 

of buzzers and beepers include alarms, timers and confirmation 

of user input such as a mouse click or keystroke. A piezoelectric 

element may be driven by an oscillating electronic circuit or 

other audio signal source, driven with a piezoelectric audio 

amplifier. Sounds commonly used to indicate that a button has 

been pressed are a click, a ring or a beep. 
 

 
 

Fig 7: Buzzer 

sensing element (MEMS structure) on one chip, and the signal VI. SOFTWARE 
conditioning electronics on another chip was used. 

 
ARDUINO UNO INSTALLATION: 

In this we will get know of the process of installation of 

Arduino IDE and connecting Arduino uno to Arduino IDE. 
 

Step 1 

First we must have our Arduino board (we can choose 

http://en.wikipedia.org/wiki/Sound
http://en.wikipedia.org/wiki/Machine
http://en.wikipedia.org/wiki/Machine
http://en.wikipedia.org/wiki/Piezoelectric
http://en.wikipedia.org/wiki/Alarm
http://en.wikipedia.org/wiki/Alarm
http://en.wikipedia.org/wiki/Oscillation
http://en.wikipedia.org/wiki/Audio_signal
http://en.wikipedia.org/wiki/Piezoelectric_audio_amplifier
http://en.wikipedia.org/wiki/Piezoelectric_audio_amplifier
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Fig 5: MEMS Sensor 

C.WATER LEVEL SENSOR: 

The Moisture sensor is used to measure the water 

content(moisture) of soil. when the soil is having water shortage, 

the module output is at high level, else the output is at low level. 

This sensor reminds the user to water their plants and also 

monitors the moisture content of soil. It has been widely used in 

agriculture, land irrigation and botanical gardening. 

 

 

 

 

 
Fig 6: Water Level Sensor 

 
• Working Voltage:5V 

• Working Current:<20mA 

• Interface type:Analog 

• Working Temperature:10°C~30°Cour favorite board) and 

a USB cable. In case we use Adriana UNO, Arduino 

Duemilanove, Nano, Arduino Mega 2560, or Diecimila, 

we will need a standard USB cable (A plug to B plug), 

t In case we use Arduino Nano, we will need an A to 

Mini-B cable. 
 

Step 2 

Download Arduino IDE Software. We can get 

different versions of Arduino IDE from the Download page 

on the Arduino Official website. We must select wer 

software, which is compatible with wer operating system 

(Windows, IOS, or Linux). 

After wear file download is complete, unzip the file. 

 

Step 3 

With a jumper, a small piece of plastic that fits onto 

two of the three pins between the USB and power jacks. 
Check that it is on the two pins closest to the USB port. 

Connect the Arduino board to wer computer using the 

USBcable. The green power LED(labeled PWR) should glow. 

Step 4 − Launch Arduino IDE. 

 

After our Arduino IDE software is downloaded, we need to 

unzip the folder. Inside the folder, we can find the applicationicon 

with an infinity label (application.exe). 

Double click the icon to start the IDE. 

Step 5 − Open our first project 

Once the software starts, we have two options 

* Create a new project 

 

* Open an existing project example. 

To create a new project, select File → New. 

To open an existing project example, select File → Example → 

Basics → Blink. 

 
Here, we are selecting just one of the examples with the name Blink. 

It turns the LED on and off with some time delay. We can select any 

other example from the list. 

Step 6 − Select our Arduino board. 

 

To avoid any error while uploading wear program to the board, we 

must select the correct Arduino board name, which matches with the 

board connected to wer computer. 

Go to Tools → Board and select wear board. 

Here, we have selected Arduino Uno board according to our tutorial, 

but we must select 

the name matching the board that we are using. 

 

Step 7 − Select wer serial port. 

Select the serial device of the Arduino board. Go to Tools → Serial 

Port menu. This is likely to be COM3 or higher (COM1 and COM2 

are usually reserved for hardware serial ports). To find out, we can 

disconnect wer Arduino board and re-open the menu, the entry that 

disappears should be of the Arduino board. Reconnect the board and 

select that serial port. 

Step 8 − Upload the program to wer board. 

 

Before explaining how we can upload our program to the board, we 

must demonstrate the function of each symbol appearing in the 

Arduino IDE toolbar. 

A − Used to check if there is any compilation error. B − 

Used to upload a program to the Arduino board. C − 

Shortcut used to create a new sketch. 

D − Used to directly open one of the example sketch. E − 
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Used to save wer sketch.F − Serial monitor used to 
receive serial data from the board send the serial data 
to the board 

 
 

Now, simply click the "Upload" button in the 

environment. Wait a few seconds; we will see the RX and 

TX LEDs on the board, flashing. If the upload is successful, 

the message 

 
 

"Done uploading" will appear in the status bar. 

Note − If we have an Arduino Mini, NG, or other board, we 

need to press the reset button 

physically on the board, immediately before clicking the upload 

button on the Arduino Software. 

 
 

VII. RESULTS AND DISCUSSION 

 

This product can be effectively utilized to 

measure various range of vibration intensity ranging from 

small to high and also for different distances. From all these 

analysis it is shown that the product can be used to detect 

minute vibrations and it helps to take preventive measures to 

avoid danger 

 

VIII. CONCLUSION 

 

Earthquake and tsunami indicator using Arduino 

mega has proved to be an economical and user friendly 

product. The product is affordable for common people in 

terms of product cost and installation cost. Frequent 

monitoring of the system is also not necessary. The product 

can be easily installed in home and industries. Power 

requirements of the system are also kept low. Precautionary 

measures are required for this product and it can be easily 

operated by the user. It is expected that the product will be 

widespread in the market due to its efficiency. The product 

can be installed in earthquake prone areas and sea shores. 

 

Advantages: 

 

1.This system is used for per warning of the natural 
hazards. 2.It is very fast and economical. 

3.One time instillation. 

 

Disadvantage: 

 

For seismic graph we are using the USB wired 

communication so range is limited. 

 

Future scope: 

 

To increase the range of the system IOT can be implemented. 
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